Author Topic: Missing "Online" Image  (Read 578 times)

Offline Skhilled

  • Newbie
  • *
  • Posts: 21
  • Once you stop learning, you stop living!
  • Referrals: 0
    • Docskillz
Missing "Online" Image
« on: April 09, 2017, 12:06:19 AM »
In the post profile with a poster's info, as seen on the left of this post and all others, the green square for showing that a user is online is missing from this theme. It's "useron.gif" and should be placed here:

http://www.davejohnson.co.uk/Themes/DeepBlue/images/useron.gif

When a user is not online you'll see a white square next to their name which is:

http://www.davejohnson.co.uk/Themes/DeepBlue/images/useroff.gif

EDIT: Your header is off on the right side at the top of the page but can be easily fixed. Open index.css for this theme and find the following:

Code: [Select]
#header {
    background: rgba(0, 0, 0, 0) linear-gradient(to bottom, #4b698b 0%, #354a62 100%) repeat scroll 0 0;
    border-bottom: 3px solid #03a9f4;
    border-top: 3px solid #03a9f4;
    box-shadow: 0 18px 20px -6px rgba(0, 0, 0, 0.75);
    clear: both;
    color: #fff;
    display: inline-block;
    margin: 0 auto;
    padding: 8px 15px;
    width: 97%;
}

Now change this:

Code: [Select]
padding: 8px 15px;
To this to fix it:

Code: [Select]
padding: 8px 30px;
Remember to backup the file before editing it. ;)
« Last Edit: April 09, 2017, 12:17:02 AM by Skhilled »
 

Offline Dave

  • Administrator
  • Full Member
  • *****
  • Posts: 410
  • Referrals: 5
Re: Missing "Online" Image
« Reply #1 on: April 09, 2017, 08:20:24 AM »
In the post profile with a poster's info, as seen on the left of this post and all others, the green square for showing that a user is online is missing from this theme. It's "useron.gif" and should be placed here:

http://www.davejohnson.co.uk/Themes/DeepBlue/images/useron.gif

When a user is not online you'll see a white square next to their name which is:

http://www.davejohnson.co.uk/Themes/DeepBlue/images/useroff.gif


That is very odd as the file was there and why it should be corrupt I do not know. Still I have changed it now and the link opens and shows the image.


EDIT: Your header is off on the right side at the top of the page but can be easily fixed. Open index.css for this theme and find the following:

Code: [Select]
#header {
    background: rgba(0, 0, 0, 0) linear-gradient(to bottom, #4b698b 0%, #354a62 100%) repeat scroll 0 0;
    border-bottom: 3px solid #03a9f4;
    border-top: 3px solid #03a9f4;
    box-shadow: 0 18px 20px -6px rgba(0, 0, 0, 0.75);
    clear: both;
    color: #fff;
    display: inline-block;
    margin: 0 auto;
    padding: 8px 15px;
    width: 97%;
}

Now change this:

Code: [Select]
padding: 8px 15px;
To this to fix it:

Code: [Select]
padding: 8px 30px;
Remember to backup the file before editing it. ;)

Believe it or not 'padding' wasn't in the file at all so I added it between margin and width and now that's fixed the error.

I used to have cleantek_20g as the default theme as I love the clean lines of it, it was sad about Crip, I didn't know him personally but he did some good work, then I saw this Deep Blue theme and liked it to and decided to have a changed. Cleantec is still a member option if they want it, but I get less people on here that you do on your site so I just sometimes change things to suit myself. The only other 'regular' member here is Choppa who is also joint admin, who I have known for years as an online friend. I didn't want to give the domain up as it's my real name and it seems a waste to have a domain name and not use it. So there you are 'A brief history' of the site  :biggrin


Thanks very much for both of those fixes Steve  :tiphat
 

Offline Skhilled

  • Newbie
  • *
  • Posts: 21
  • Once you stop learning, you stop living!
  • Referrals: 0
    • Docskillz
Re: Missing "Online" Image
« Reply #2 on: April 09, 2017, 01:26:03 PM »
I've cleared my cache and can now see the online image. :)

Hmm, then it might have been using some of the code from the default .css file. Whenever there's something not added to a theme and it calls for it, it will take it from the default theme. It's there...somewhere. LOL I could see it. To play around with themes press the F12 key and the web developer should open. In the center is the code fpr the templates. On the right is the code for css. You can edit them and see how things will look immediately onscreen. Changing pages or refresh by pressing F5 to clear what you've done.
 

Hobbies

 

Garden Guru